ERROR: Response object error 'ASP 0156 : 80004005'
Symptoms
When trying to login to RMTrack you recieve the following error:
Response object error 'ASP 0156 : 80004005'
Header Error
/RMT/Login.asp, line 170
The HTTP headers are already written to the client browser. Any HTTP header
modifications must be made before writing page content.
Cause
Response buffering is not enabled on the RMTrack virtual directory.
Resolution
To resolve this problem you must enable response buffering using the Internet Information Services Manager:
- Start IIS Manager
- Under Windows 2000: Start->Settings->Control Panel->Administrative Tools->Internet Services Manager
- Under Windows 2003: Start->Settings->Control Panel->Administrative Tools->Internet Information Services (IIS) Manager
- Locate the RMTrack virtual directory. By default this is located in the Default Website and is named RMT.
- Display the virtual directory’s properties by right-clicking and selecting the Properties choice.
- On the "Home Directory" tab ("Directory" under Windows 2003) click the "Configuration..." button near the bottom right of the dialog
- Switch to the "Options" tab of the Application Configuration dialog.
- Check the "Enable Buffering" checkbox
- Click OK to close the Application Configuration dialog.
- Click OK to close the Properties dialog.
References
- http://support.microsoft.com/default.aspx?scid=kb;en-us;229657 PRB: ASP 0156: 80004005 Header Error
Status
Corrected in v2.3.0. Buffering is explicitly enabled by the installer.
Applies to
RMTrack Issue Tracking – all versions prior to v2.3.0